Ask a question

284 questions

328 answers

250 comments

3201 members

Ask a question
+1 vote
32 views
in Smart Autonomous Solutions by

We purchased 2 x RFID readers from Varia Store (https://www.varia-store.com/en/produkt/84101-priedasraj-1-wire-rfid-reader-125-khz.html) which I understand are manufactured by Teltonika.

We wired it up to a TFT100 according to the instructions here: https://wiki.teltonika-mobility.com/wikibase/index.php?title=1-Wire_RFID_reader

Blue on the TFT100 -> White on the RFID Reader (1-wire data)

Yellow on the TFT100 -> Brown on the RFID Reader (VCC+)

Black on the TFT100 -> Green on the RFID Reader (GND)

And absolutely nothing happens when we scan a variety of RFID cards, nothing is shown on the iButton I/O menu in the configurator.

We used an oscilloscope to probe the Blue line and we can see some activity every few seconds, but nothing when an RFID card is touched to the reader. Also, when the RFID reader is disconnected from the TFT100 and we scoped the Blue line, the same activity is seen, thus the reader does not seem to be doing anything.

We probed the Yellow line on the TFT100 and found it was only outputting 5V, and the RFID reader required minimum 6.5V according to the datasheet, so we changed the wiring such that Brown (VCC+) on the reader goes to the Red line on the TFT100 (+10V), and the result is unchanged.

We powered the RFID reader on its own from a power supply, fed 6.5V to 10V and the White line shows no activity on the scope at any time. We tried both RFID readers that we bought, and the same result.

To add to the confusion, the wiring diagram here is different: https://wiki.teltonika-gps.com/view/1-Wire_RFID_Reader

Green -> 1 Wire Data

Red(??) -> VCC

Black(??) ->GND

Any help would be appreciated, how is this supposed to be wired up, and why is there no activity seen on the 1-Wire data line when a card is placed there or not?

Thank you

1 Answer

0 votes
ago by

Dear Peter

Greetings!

I suggest you connect wires flowing to the sticker on top of the TFT device

The color code that you mentioned is correct

  1. Blue on the TFT100 -> White on the RFID Reader (1-wire data)
  2. Yellow on the TFT100 -> Brown on the RFID Reader (VCC+)
  3. Black on the TFT100 -> Green on the RFID Reader (GND)
To be on the same page, Have you checked the card frequency or even change it? 
The card frequency should be 125KHZ
In case the issue is still, please, reach out to your sales manager, where you can create a VIP ticket and get a solution to your issues
Thanks!