Ask a question

284 questions

328 answers

250 comments

3201 members

Ask a question
0 votes
45 views
in Smart Autonomous Solutions by

Hi!
i have just flashed the 55.00.16.Rev.522 firmware on my TAT100.
After that I wanted to flash the BlueNRG firmware as well but it doesn't work.

I tried it via the Configurator and via Fotaweb.
In the configurator it hangs on initializing target firmware flashing and in fota web it says it was successful but when I connect the configurator it doesn't show a version on the info page.
It should be Firmware version: 10.X.X   55.X.X but mine only says Firmware Version:         55.x.x

The device also gets no GPS Fix and tells me the battery is 0 V.
Only the test connection button works, but sends an old entry. (RTC is not synced....)

Can some please help me?
Thanks Alex

2 Answers

0 votes
by

ok I tried to debug as far as possible:

The configuration utility updates the 55.00.16.Rev.522 firmware all the times.
When I try to update the BlueNRG the tool hangs at "initializing target firmware flashing"

After that I have to disconnect the usb cable to get a connection again.
I debugged it on the serial port and it hangs after the command @asset_transport
the device replys with "ASSET TRANSPARENT MODE." and than nothing happens.

Can some please help me to get it working again?

0 votes
by
Hello,

Could you please provide this device IMEI? And have you tried replacing this device's battery?
Please check if the TAT100 battery is plugged in and attach the dump file if possible. ( It can be done using Teltonika Configurator -> Maintenance -> Dump )

Best regards
by

Hi!
Sorry for the delay, the battery died before (1. battery had inverted polarity)
I removed both batteries and applied a fixed power source for testing.
Imei: 352625695264687
Device is currently switched on.
Dump files:  dump dump2

Regards Alex