Ask a question

321 questions

404 answers

306 comments

6426 members

Ask a question
0 votes
467 views
in Smart Autonomous Solutions by
Hello,

I am trying to use Wireguard on a RUT955. I have previously done this prior to a firmware update. I recently updated to RUT9_R_00.07.01.1_WEBUI.bin. This version includes Wireguard and so no need to install a module. However I cannot get it to function.

I am able to configure it via the HTTP/S GUI. However, when I enable it nothing happens. When I SSH onto the device and search for any sign of Wireguard, I get nothing. It does show with 'lsmod' but not modprobe, any logs, or searching for wg*.conf.

I also see nothing in any logs on the GUI.

Can someone please confirm that the built-in Wireguard module is functional and help me configure / work it please.
by

After performing a factory reset I have managed to get a connection. However, I am still struggling to find the configuration files to allow more advanced settings. Also there is very little logging I am able to see. I can only get a few lines from dmesg:


root@Teltonika-RUT955:~# dmesg | grep wireguard
[   24.585011] wireguard: WireGuard 1.0.0 loaded. See www.wireguard.com for information.
[   24.593022] wireguard: Copyright (C) 2015-2019 Jason A. Donenfeld <Jason@zx2c4.com>. All Rights Reserved.

root@Teltonika-RUT955:~# wg
interface: aws
  public key: <>
  private key: (hidden)
  listening port: 51820

peer: <>
  endpoint: <>:51820
  allowed ips: 192.168.0.0/24
  latest handshake: 1 minute, 16 seconds ago
  transfer: 32.48 KiB received, 713.59 KiB sent


2 Answers

0 votes
by

Good morning,

This forum is for Mobility devices.
Your request is related to RUT device and should be registered in another forum.
Please, contact our colleagues at: https://community.teltonika-networks.com

Bast Regards,

0 votes
by

I finally got it to connect after doing a factory reset. Though I've made some progress, I can't seem to track down the configuration files that would enable the more complex options. geometry dash