Ask a question

219 questions

253 answers

228 comments

1389 members

Ask a question
0 votes
241 views
in Smart Autonomous Solutions by

Dear Sir or Madame,

recently I have purchased a TAT100 for testing my scenario. I already received it and managed to download the configurator. (Unlike the FTM100 or FMB204 there is no restricted access to the configurator).
So far I could connect to the device and saw that I have a older firmware (55.00.05 Rev: 510) - can you please tell me where I can get the latest firmware? The FW Download page has only the configurtor sw for download but no firmware.
I saw some differences between the getting started guide and the actual UI...

My second problem is that I have already a FOTA Web account and wanted to register that device there. In the UI it gives me no errors but doesn't show up. Via the API it says it is already registerd!? So how can I register this device? (My FotaWeb Account is a SubAccount of another shop where I have purchased the 2 other trackers but NOT the TAT100...)

Whenever I had questions about the 2 other devices I have talked to Mr Dainius Pupelis but he told me that this is a different department/company...

So can someone please help me and tell me who I can contact so I can add the device to my account?

BTW: My TAT100 device says "Engineering Sample" on the top - is that different from the production unit?
I have also found some bugs with the API / Documentation:

The links to the Postman Collection & Swagger don't work (Error 404)

Whenever I get my company details (or some other response with paginagtion) the paginator returns a link ("url": "http://localhost:8000/companies?page=1,) which I think should point to the FOTA api domain?

Kind regards
Alex
PS: Answers are possible in English or German...

1 Answer

0 votes
by
Dear Alex,

Judging by the firmware version, the device must have an older hardware, which means that newest stable release firmware versions displayed on the website are not compatible with your current device hardware.

Regarding the device registration on FOTA WEB, please send me a private message with device IMEI and your assigned company name.

Please contact your Sales manager, we can discuss the issue through HelpDesk.

Best regards,

Simonas
by

Hello

I did some more testing with my new two TAT100.

They are also engineering samples according to the label. 

Firmware 55.00.05 Rev:510.

First TAT100:

It sent a single record to Ruhavik after I configured APN, IP address and port by SMS. It has not sent another record since no matter what I tried. I currently have scheduled tracking with one record daily. The RTC did never update, its somewhere in 2014.

Sent records show as zero even though it sent a single record to Ruhavik.

It connects to FOTA Web OK, no firmware available. My trackers have build 510.

I reset the tracker and set the APN, IP and port and the schedule using the dedicated TAT100 configurator.

I sent web_connect by sms and received reply web_connect OK.

I tried a different SIM card.

Both LEDs are always on after plugging in USB (which I try to minimize).

Slider switch is on.

Second TAT100:

Configured APN, IP and port using the configurator. Got record in Ruhavik without problem.

It connects to FOTA Web OK, no firmware available. My trackers have build 510.

Sent records show as zero even though it sent at least one record to Ruhavik.

Only one LED is constant on when USB is connected no matter what I do.

Slider switch is on.

Questions:

What do the LED's mean? I searched but couldn't find that.

Where is the test connection button? (Mentioned in the wiki.)

Where is the start delay and stop delay for tracking? (Mentioned in the wiki.)

What can cause RTC update to fail? Remember, it gets a connection to FOTA.

Where is the button to enable GPRS? (mentioned in the wiki). There is only "GPRs context".

Thanks in advance for all help.