We would like to announce that Teltonika Telematics and Teltonika Mobility have joined forces!

As a result of the merge, from 2022-12-01 this forum will be left only as an archive for already existing Mobility related topics and questions.

We kindly ask all new and existing users to create and address your questions related to Mobility products on the Teltonika Telematics crowd support forum

We will meet you there!

Ask a question

334 questions

422 answers

324 comments

7594 members

Ask a question
0 votes
636 views
in Smart Autonomous Solutions by

Hi,

When I response to device with records size the response is not accepted and send same records again and again.

These are some logs:

Response to records looks not accepted (It says nothing about response but records are not marked as sent)

[2020.06.22 15:39:46]-[CODEC.APP] Rec found at 0x00000000, sort:0

[2020.06.22 15:39:46]-[CODEC.APP] Done packing high prio recs:2

[2020.06.22 15:39:46]-[NETWORK] attempting to send data by VR socked id: 1, data len: 139

[2020.06.22 15:39:46]-[NETWORK] data send to socket: 1, successfull! evt sending: enabled, VR socket: 0

[2020.06.22 15:39:46]-[NETWORK] [SEND.DATA.0772] Waiting for socket send result, waiting: 10 sec

[2020.06.22 15:39:46]-[REC.SEND.1] records packed: 2, waiting 120 sec for answer

[2020.06.22 15:39:46]-[REC.SEND.1] link timeout reset for server: 0

[2020.06.22 15:39:47]-[IO.APP] Ignition changed:0->1 (0)

[2020.06.22 15:39:47]-[ModeChange] Unknown on Moving profile is updated and reloaded

[2020.06.22 15:39:47]-[REC.SEND.1] Periodic sending already started @ main server, state: 5 / send records

[2020.06.22 15:39:47]-[TRACK] MinPeriod record action [3=<3]

[2020.06.22 15:39:47]-[TRACK] Periodic Record Action!

[2020.06.22 15:39:47]-[REC.GEN] Periodic low priority record saved @ 0x0000002A

[2020.06.22 15:39:47]-[REC.GEN] Record Content:

Timestamp: 1592840387000

Priority : 1

Latitude : 0.0000

Longitude: 0.0000

Altitude : 0

Angle    : 0

Speed    : 0

HDOP     : 0.0

SatInUse : 0

GPS Fix  : 0

GSpeed   : 0, src: NONE

Event AVL ID : 0

IO ID[240]: 0

IO ID[ 21]: 4

IO ID[200]: 0

IO ID[ 69]: 2

IO ID[113]: 99

IO ID[181]: 0

IO ID[182]: 0

IO ID[ 24]: 0

IO ID[ 67]: 4277

IO ID[ 68]: 0

IO ID[241]: 21403

Record Size: 116 Bytes

[2020.06.22 15:39:47]-[NETWORK] [IND] received data from socket!

[2020.06.22 15:39:47]-[NETWORK] notification, socket id: 1 has data which must be read!

[2020.06.22 15:39:47]-[NETWORK] VR socket 0, real socket id: 1, attempt automatic data reading for application

[2020.06.22 15:39:47]-[NETWORK] attempting to read data from socked id (real): 1

[2020.06.22 15:39:47]-[NETWORK.PARSER] Parsing data from 0 socket, data len: 1

DUMP DATA START:

02 

DUMP DATA END

[2020.06.22 15:39:48]-[OVERSPD] Scenario disabled!

[2020.06.22 15:39:50]-[TRACK] MinPeriod record action [3=<3]

[2020.06.22 15:39:50]-[TRACK] Periodic Record Action!

[2020.06.22 15:39:50]-[REC.GEN] Periodic low priority record saved @ 0x0000002B

[2020.06.22 15:39:50]-[REC.GEN] Record Content:

Timestamp: 1592840390000

Priority : 1

Latitude : 0.0000

Longitude: 0.0000

Altitude : 0

Angle    : 0

Speed    : 0

HDOP     : 0.0

SatInUse : 0

GPS Fix  : 0

GSpeed   : 0, src: NONE

Event AVL ID : 0

IO ID[240]: 1

IO ID[ 21]: 4

IO ID[200]: 0

IO ID[ 69]: 2

IO ID[113]: 99

IO ID[181]: 0

IO ID[182]: 0

IO ID[ 24]: 0

IO ID[ 67]: 4276

IO ID[ 68]: 0

IO ID[241]: 21403

Record Size: 116 Bytes

[2020.06.22 15:39:51]-[AXL.CLBR] Waiting... (Fix:0 Ign:1)

[2020.06.22 15:39:52]-[REC.SEND.1] Mode: 5/Unknown on Moving. Time for next periodic data sending: 2 / 3

[2020.06.22 15:39:53]-[MovDetect] state changed 1 -> 0 (movI:1, movD:1, spd:-1, delay:5)

[2020.06.22 15:39:53]-[MovDetect] Delaying movement 1 -> 0, cnt:1 tmo:60

[2020.06.22 15:39:53]-[ADC] Measured Values Table:

[VBat, mV      ]: 1.000 (4255) 0

[ICharge, mA   ]: 1.000 (0) 0

[Bat.Temp, 10C ]: 10.000 (312) 0

[VCharge, mV   ]: 1.000 (0) 0

Using Conv Table:Handheld CalibVals:1

[2020.06.22 15:39:53]-[TRACK] MinPeriod record action [3=<3]

Some config:

Thank you

Jesus

1 Answer

0 votes
by
Hello

Please check your device communication with out AVL listener:

Download link:

https://drive.teltonika.lt/d/5ab28c3d0d1c4f66bc32/

Pass: przTz8CF
Best answer
by

Hi

The problem was that I was sending only 1 byte for data response instead of 4 bytes.

https://wiki.teltonika-sas.com/view/Teltonika_data_sending/receiving_protocols#Codec_8

Thank you guys for you support

Jesus